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4 What We Do On the Web

The Web is a tool for distribution. Anything that can be digitized can
be made available to the public: music, software, news, books,
images, recorded speeches, recipes, grandma’s last will and testa-
ment. Anything. The only difference between these items is how they
are presented to an audience. Music comes in MP3 formats. Video
news feeds are often in G2 format from Real, Inc. But the majori-
ty of information is presented in some form of markup language.
The most common of these languages is HTML. And it is from
HTML that most Web site designers derive their need for artwork.
HTML-based pages are often static, meaning they are created
once and sit as a file on a Web server waiting for users to request
them. Some pages are dynamic. These are pages that are gener-
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ated right as the user requests them. Dynamic pages put a heavy
load on a server with many visitors, so small companies and
small Web sites often try to generate static pages on a scheduled
basis instead of loading the server with dynamic requests. In
either case, HTML pages are usually chock full of graphic images:
logos, background images, navigation buttons, animations, and
thumbnails. Each of these serve a different purpose and have dif-
ferent requirements for the designer. Fortunately, none of them is
very difficult to produce with the GIMP.

Logos are used to identify a site, product, trademark, corpora-
tion, or individual. They are generally images which show up on
just about every page of a site. Background images are placed
behind text or other images. They provide a style or theme for a
Web page. Although they provide no real functionality for a site
(the site can usually exist without the background image), they are
a key component for presenting a site’s identity. Because they are so
key to an identity, logos are often used as background images.

Animations are most useful in advertisements, however, I
can't in good conscience encourage their use. Web-based inline
animations are only available using the GIF file format, which
supports animation in about the same way a “page flip” book
supports it. Both work and both are extremely inefficient (would
you rather watch page flip books or a movie?). Still, you can’t
avoid their use on the Web. Animations are a moderately com-
plex topic and will be discussed briefly here in Part 3.

Navigation buttons include rectangular, oval, and randomly
shaped images used to move around a Web site. An alternative to
buttons are image maps, which are ordinary images with various
regions linked to other areas at the site. You'll often see naviga-
tion buttons used when you move a mouse over some text and it
changes color or shape—these are known as JavaScript rollovers.
Each of these buttons is actually two different images: the one dis-
played when the mouse is over it and the one displayed when the
mouse is somewhere else. Image maps do not change when you
move the mouse over them, although the status bar at the bottom
of the browser window may show the destination link depending
on where the mouse is over the image. Most of these images are
created before the Web page itself is created. The images are stat-
ic. But for some situations a dynamically created image is more
desirable. Stock price charts are an example of dynamically cre-
ated images. The GIMP’s scripting interface allows you the option
of using it in batch mode, which means the user interface is not
started. This allows programs to run unattended to generate
images. We'll look at scripting with the GIMP in Part 4.
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¢ What GIMP Does for the Web

The GIMP provides a means of creating images for use on the Web
(it can also be used for print, but that topic is beyond the scope of
this text). Images can be created from scratch, like logos or back-
grounds, or manipulated from scanned or other digital images.
You can create image maps, buttons, galleries of photos, or even
cut up an image to fit into an HTML table.

What you can’t do with the GIMP is generate programmatic
interfaces to your pages. This is known as CGI (for server-side pro-
grams) or JavaScript and Java (for client-side programs). Such
programs, even though they may generate images or automate
the display of images, are usually created manually using a pro-
gramming language like Perl. Perl can also be used with the
GIMP, but the GIMP does not generate Perl code.

¢ The User Interface

If you've ever worked with Adobe Photoshop then the GIMP’s user
interface should be familiar to you. The initial window consists of
a number of rows and columns of buttons with a menu bar at the
top—this is the Toolbox. Each button enables a different tool for
use in the Canvas. Figure 1-1 shows the Toolbox. Note that single-
clicking on a button sets the tool mode to that tool. Double-click-
ing on the button sets the tool mode and also opens the Tool
Options dialog. Most tools have configurable options. This dialog
remains open when you change tools, and will display the
options (if any) for the currently selected tool.

Canvases are where you do your drawing, painting, and so
forth. Figure 1-4 shows a blank Canvas and some of its features.
You can open a new, blank window using either the File->New
menu option from the Toolbox, the File->New menu option in the
Canvas menu, or by typing Ctrl-N in either the Toolbox or a
Canvas window(Ctrl-O will open an existing image). You will be
given an option as to what the window will display—either a
transparent (i.e., empty) background, a white background, or the
current foreground or background colors.

Each Canvas is made up of rulers along the left and top sides,
scrollbars on the bottom and right sides, the display area (usually
white in a new window), a status bar below the bottom scrollbar, a
pop-up menu, quick mask buttons, and the Navigation Preview but-
ton. All of these are initially visible (the menu opens when you
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FIGURE 1-1 The GIMP Toolbox

FIGURE 1-2 Foreground/background
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{ FIGURE 1-3 Brush, pattern, and gradi-
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click on its arrow or when you press the right mouse button inside
the display area) and most can be toggled off (invisible) using the
File->Preferences option in the Toolbox. There are other features
which are not visible: multiple layers (only the background layer
is created initially, you'll create others later) and guides. Guides are
created by clicking in one of the rulers and dragging it into the dis-
play area. A guide is just a straight line to which selection outlines
and layer edges can be attached, making alignment much sim-
pler. We'll see these in action in later chapters.

Closing the Canvas window is done by typing Ctrl-W in the dis-
play area. If changes have been made to the window you will be
asked if you want to save them. Closing the Canvas window does
not exit the GIMP. To exit, you select File->Quit from the Toolbox or
Canvas window menus or just type Ctrl-Q in any window.

The GIMP understands most common image file formats,
ranging from JPEG and GIF to TGA, TIFF, XPM, PCX, Postscript,
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PNG, and WME If you open an image and it’s too large for the
display, or if you resize the Canvas window, you can move around
the image within the display area in three ways. First, moving the
scrollbars will get you around. Second, the middle mouse button
when clicked (or, if you only have two buttons, then both pressed
at the same time) and dragged will do the same thing. Finally, a
new feature to 1.2, the Navigation Preview, allows you to see a
thumbnail version of the image with an outlined region showing
the display area of the Canvas window. You can drag the outline
around the thumbnail and the Canvas window’s display area is
updated accordingly.
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FIGURE 1-6 The Navigation Preview

Although you can change the resolution (number of dots per
inch, for example) for the image, you won’t need to do so for Web
images. The default is 72DPI, and the rulers along the sides of the
Canvas window will show units in pixels. You can change from
pixels to inches for the units used in the rulers, although this
probably won'’t be all that helpful. Such features are more impor-
tant to artists working on images destined for print.

The Canvas window menu is an important part of the GIMP.
If you're used to the Microsoft and Mac world of applications,
you're probably expecting a menu bar to access features. The
GIMP is designed for artists, who value screen space on their mon-
itors like movie producers value summer blockbusters. Because of
this, you'll find a number of features designed to save screen
space. The Canvas window menu is one such feature. The menu
can be accessed by clicking on the menu arrow in the upper left
corner of any Canvas window or by pressing and holding the
right mouse button in the display area of the window. The GIMP
uses the notion of an active window, which means that the menu
item you select is applicable to the window which is active. Which
window is active depends on which window was last clicked in.
Want to make a Canvas window active and not take the chance
of accidentally making changes to it? Click in the status bar over
the name of the window.
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The Canvas menu gives you access to nearly all the features of
the GIMP, including those found in the Toolbox (only a few
options under the Xtns menu in the Toolbox are also not avail-
able here). This menu contains a number of submenus, including
options for editing (cut and paste), selecting (feathering, growing,
shrinking, and so forth), and the vast set of color and effects fil-
ters. If you want quick access to it, you can tear off the menu and
it will then get its own window. This can be confusing if you have
multiple Canvas windows open since the menu is Canvas-specif-
ic. Fortunately, the GIMP knows which window the menu belongs
to. However, if you use tear-off menus you’ll need to keep track of
which ones they belong to on your own since visually it will not
be obvious. The key: don't use tear-off menus.

4 Saving Your Work

We've already talked about opening existing image files and
starting with a blank Canvas window. Once you’ve completed
your work (and if you're smart, periodically while you're work-
ing), you'll want to save the image. The GIMP has its own file for-
mat called XCF (an acronym for the Experimental Computing
Facility at Berkeley where the GIMP was born). If your image has
more than one layer and you specify to use filename extensions
to identify the file and also specify “.xcf” as the suffix to the file-
name, then your image will be saved in an XCF formatted file.
This is good—all the information that the GIMP knows about
while running will be saved here. If you choose another suffix, say
.jpg or .gif, then GIMP will try to save the image using these for-
mats. This can be troublesome if you have more than one layer
since JPEG images, for example, don’t understand layers or mul-
tiframed images. The key here is to use the right format for the
job. Save your work in a XCF format at all times until you're
ready to flatten the layers (which means to combine them into a
final, single layer). At that time, with a single layer, you can save
it to some other file format. We’ll talk more about the differences
between GIF and JPEG in Part 3, where we get into the meat of
imaging for the Web.
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FIGURE 1-7 The Save As dialog

4 Terminology—You Say Potato, | Say Option
Menu

One of the problems with working on multiple computer plat-
forms is terminology. There are standards for terms, and the geeks
among us are used to them, but the average person needs a little
primer every now and then. Well, here’s yet another primer.

The GIMP uses terminology which is similar to, but slightly
different than, PC and Mac systems. Mac users may be familiar
with the term “palette” when describing a window that pops open
in response to selecting a menu item, for example. In the GIMP
(and on LINUX and UNIX systems in general), these are referred
to as “dialog boxes.” We'll refer to just about every window that
opens in the GIMP that isn’t either the Toolbox or a Canvas as a
dialog box of some sort.

Dialog boxes contain buttons, scrolled lists, and other things.
One of the less familiar items can be found in the Layers and
Channels dialog (type Ctrl-L in a Canvas window to open this dia-
log). Here you'll find a notebook with three tabs labeled “Layers,”
“Channels,” and “Paths.” Clicking on the Layers tab puts you on
the Layers page of the notebook. Clicking on the Paths tab puts
you on the Paths page. Easy enough once you know the terms
we’ll be using.

Menus are also a little confusing since they come in various
forms. The traditional menu is called a pull-down menu, like the
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FIGURE 1-8 Layers and Channels dialog

menu you get when you click on File in the Toolbox’s menu bar.
This is also known as a pop-up menu. Some menus are presented
like a button, so that when you click on it the menu opens with
the currently selected menu item displayed over the button.
Change the selected item and the button’s text changes when the
menu closes. These are called option menus. Usually, option menus
are used in places where only a few options are available. Pop-up
menus are used in most other places. Tear-off menus are versions
of pop-up menus; you can identify these by the dashed line across
the top of the menu. Click on the dashed line to tear off the menu.
Click on it again to close the window the menu is placed in after
being torn off.

The last bit of terminology has to do with buttons. You're
familiar with simple push buttons—click on them and something
happens. Alternatives to this are radio buttons, which are a series
of diamond (usually) shaped options. You can click on only one
of these—they are mutually exclusive. The other possibility is an
ordinary toggle button. Click it once to turn it on and it appears
depressed into the screen. Click it again and it is disabled, mak-
ing it appear like it is sticking out from the screen. Radio buttons
are just a series of interrelated toggle buttons.

It’s an easy bit of terminology but important to understand as
we go through this text. But don’t let yourself get swallowed up by
the terms—the GIMP is a tool for getting work done. When in
doubt, forget the terms and just experiment for a while. You can
always come back and put names to features later.
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¢ Features You'll Learn to Love

There are many features in the GIMP with which you will become
very familiar over time. A few of these are important to point out
right from the start. Without an understanding of these, you may
find your work a bit more tedious.

The Layers and Channels features, the dialog of which you've
seen previously when we talked about terminology, are indispensi-
ble to the GIMP artist. Layers in particular will be used often, even
for the most minor of artwork. These can be thought of like a series
of clear acetate sheets laid one atop the other. The final image is
viewed through these sheets; this is known as the composite image
(compositing means to combine the layers). An example of the use
of layers is in the creation of shadows. The top layer may contain
some text, below which is a blurred and offset copy of the text. The
composite of these two layers gives the appearance of the text lying
above the background a sort of 3D appearance.

The Layers and Channels dialog has many options for
adding, deleting, moving, and managing layers in general. You'll
be creating masks for layers—regions which are blocked from use
in the composite image—as well as applying different methods of
composition for each layer. Finally, the Layers and Channels dia-
log also contains the new Paths option, which allows you to cre-
ate and edit lines and curves in your image. We'll discuss layers
in more detail in Chapter 2, “Layers.”
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FIGURE 1-9 The Curves and Levels dialogs
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Color management is another area you'll be dealing with on
a daily basis. Most of the color tools are found in the Canvas
menu, under the Image->Colors option. Tools like Curves, Levels,
Hue/Saturation, and Desaturate are all used to manage colors
globally within a layer or within a selection (selections are a dis-
cussion on their own, and we'll deal with them in Chapter 3,
“Selections and Masks”).

Finally, effects filters are where you are most likely to want to
jump to right now. The heck with all this basics stuff—show me
the fractals! Well, if you're into experimenting, open a new
Canvas window and try out the Filters->Render options from the
Canvas menu. The menu options here all lead to effects filters
which render (i.e., draw) images without or with little regard to
the image’s current contents. In other words, they are cool to play
with and you don’t need any existing image to do something fun
with them. But once you're done there, come back here. There are
a lot of other effects filters, and they all have important purposes
for the Web.
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FIGURE 1-10 The Flame dialog and the Render filters menu
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Recap

We’ve covered some basics here, an introduction for those who
are brand new to the GIMP and the Web. Getting started with a
new tool often requires a little help with understanding what it is
you're looking at, and that’s what we’ve done in this chapter. But
we're just getting started. In the next chapter we're going to look
at layers, one of the most useful core features of the GIMP.
Understanding layers is key to understanding how both static and
animated images are made. Without layers, there would be no 3D
effects, no drop shadows, no beveled edges. We'll look at what lay-
ers are and how to do something useful with them.



